Post reply

Message icon:


shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: RTT
« on: June 06, 2014, 09:43:04 AM »

In that Windows Search advanced options, and for the option you have selected for the PDF file type, it should show also "file properties filter", so it seems that the PDF property handler is not correctly registered.
Run the manager and check if the PDF-ShellTools property handler shows as registered.

Run this tool and send me by email (get the email address from the manager about box) the text that will show, so I can inspect your system PDF-ShellTools related settings.
Posted by: Tegglet
« on: June 06, 2014, 08:58:18 AM »

I have just discovered how to add a tag using the "Details" tab. :).  Back in the day, Windows was intuitive, now you have to be clairvoyant! >:(

I cannot add tags to PDF files but can on others (I have tried Word and Excel files).  Is this a "Feature" of PDF files?  Unfortunately, the job in hand uses PDF files exclusively so I cannot proceed until this problem is resolved.
Posted by: Tegglet
« on: June 06, 2014, 08:40:04 AM »

FYI: This is an area in which I have little expertise and I saw the PDF-Shell Tools as a way of doing what I wanted without being diverted from my main task.  I am happy to re-allocate some time to solving the problem but please be patient with my ignorance. ;-)

How do I edit the metadata from the files "details" tab?  I appears to be read only.

I am reluctant to rebuild the index due to the time it appears to take, although if I have to I will do it overnight.  The trouble here is that even if I start it now it will take me into the weekend by which time I was hoping to have the problem solved so I could get on with the original job.

I did wonder if the problem was down to accessing a file from a network share so I installed PDF-Shell Tools on the server and tried it from there but got the same problem.

In the interests of simplification, I saved a Word document as a PDF in the local temp directory and the problem persisted.

I have just opened the test file and found the test field has retained its value.  I tried adding a value to a second field and saved the file getting the same error.  I cancelled out and re-opened Properties>InfoEdit but both fields were blank.

Inspection of the Indexing options shows that the pdf extension has a different filter description; is this relevant?  See snippet attached.
Posted by: RTT
« on: June 06, 2014, 12:56:44 AM »

Do you get similar error if you edit the metadata from the file properties "details" tab (or from the Windows Explorer file details pane), instead of from the InfoEdit one? A different shell extension, the property handler, will be used in this case.

If the folder where you have the PDFs is being indexed by the Windows Search service try to rebuild the Windows Search index. If problem persists, and just for testing proposes, remove that folder from the list of folders to index. If the folder is included in a library, remove it from the library too and test again.
Posted by: Tegglet
« on: June 05, 2014, 11:13:47 PM »

I had already tried deleting the file, which appeared to be successfully deleted without protest.  When File Explorer was refreshed however the names of the deleted files were listed but could not be opened.

I have now tried Microsoft/SysInternals Process Explorer as you suggested but without success.  The search gave zero results but the Acrobat Reader is listed and shows the filename when the mouse pointer is hovered over the entry.  When Acrobat Reader is closed the entries are highlighted in red then are cleared.

All this makes no difference to saving the file.
Posted by: RTT
« on: June 05, 2014, 10:33:46 AM »

A rapid way to detect what process is locking a file, in Windows 7/8, is to delete the file. A dialog will show up, after the confirmation question, stating the impossibility to delete the file and the involved process name.
You may also use the Microsoft/SysInternals Process Explorer. Go to Find > Find Handle or DLL. In the "Handle or DLL substring:" text box, type the path to the file (e.g. "C:\path\to\file.pdf") and click "Search". All processes which have an open handle to that file should be listed.
Posted by: Tegglet
« on: June 05, 2014, 09:02:35 AM »

I have just started using the trial version of PDF shell Tools and having scanned in a batch of paper documents.  I want to split out the pages and add tags, titles etc., to each file.

Populating the fields under the InfoEdit tab in the document properties has worked once but now when I try to apply a change I am getting the error "Unable to edit file - The process cannot access the file because it is being used by another process" displayed; see attachment.

I cannot identify the process concerned and have tried closing all PDF files, closing File Explorer, and even killing and restarting explorer.exe in Task Manager.  I have yet to try a reboot but would rather identify the cause first if possible.

Can anyone help please