Post reply

Message icon:


shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: RTT
« on: May 14, 2010, 11:08:48 PM »

Yes, it is fixed now and this fix will be included in the next full version release. Right now I'm a bit busy coding other things, but I hope to have some time soon to finish, and public release, the new version.
So keep in touch, and continue to use the workaround for some more time. When new version online, it will show up in the updates and a new release notification email will be sent to all the registered users.
Posted by: pk72
« on: May 14, 2010, 07:53:46 PM »

RTT, did you fix this? How can I get an update? The update-function in the "shell tools manager" offers only localization updates, no updates of the program. Can I download and install the current version with my key?
Posted by: RTT
« on: April 03, 2010, 12:25:15 AM »

Excellent finding Philipp!
Knowing this, I discovered that files created in folders with the advanced attribute "Index this folder for faster searching" unset, result in files with the "Index this file for faster searching" attribute also unset.
That's exactly what is happening here. The tool creates the new file at the system temp folder, usually disabled for indexation, so, when the tool moves the new pdf to the destination folder, result in a file not enabled for indexation.
I'm now adding code to fix this issue. Meanwhile, as a workaround, you can easily fix this enabling the system Temp folder "Index this folder for faster searching" advanced attribute. Just type %temp%, at Windows Explorer address, to easily locate it.
Posted by: pk72
« on: April 02, 2010, 10:38:48 PM »

I found why the files with removed security will not get indexed: There is a file attribute to allow a file to be indexed (I can't state the checkboxes text in the file properties dialog cause I am working with a german localisation). The normal file attribute under properties/details is "A" while for the files with removed security it is "AI".
Best, Philipp
Posted by: RTT
« on: March 18, 2010, 02:25:42 AM »

The tool just rename the original file and move the, in system temporary folder, created one to the directory of the original, giving it the same name. Because the backup file, and new one, are equal, and because you say that even when rebuilding the index the new one don't get indexed, I really don't have a clue for what's going on.
Can't be an ifilter file compatibility problem, because files are equal. The only thing that is left is file access rights (and this is compatible with moving file to another disk and back on), because an index rebuild should include any file, so a possible bug in the indexer code that identify what files need to be indexed is not a possibility here. Do you know if the indexer service, or the Adobe ifilter, can log to file?
Posted by: pk72
« on: March 18, 2010, 12:17:37 AM »

RTT, I checked again:although the files are identical on a binary level, one of them got indexed on my computer (the backup file), the output file from security removal was not. It must be a problem with the NTFS file system, because when I move the "corrupted" file to a USB flash drive and back to my (flash) harddisk the file will get indexed again.
I also checked with files that had security turned on. The output files with removed security were different of course, otherwise the same thing, they do not get indexed.
I also checked with A-pdf restriction remover, no problem there with the output files.
I run Win 7 proffessional.
Any ideas?
Posted by: RTT
« on: March 17, 2010, 12:08:24 AM »

Hi Philipp,
The two files you attached are equal, without password security applied, and don't present any anomaly! Probably you messed something while attaching?
Posted by: pk72
« on: March 16, 2010, 08:30:26 PM »

Hi, I removed the security from some pdfs (I used the command line but later checked with the shell extension as well). After that I found I was no longer able to search in these pdf files (windows 7 search, metadata and full text, adobe i-filter). I tried to rebuild the search index, no use. The backup-files could still be indexed.
I attached a corrupted (?) file and the backup file that still works.
Thanks, Philipp