Post reply

Message icon:


shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: Ed Kopta
« on: September 07, 2018, 08:40:19 PM »

That did the trick, thanks. I did stumble a bit, thinking I had found them all. However one of the keys down in the tree was selected when I searched. More were found after I selected root nodes. People more familiar with the registry editor may have known how to do that properly, but I had to learn from experience. Thanks again.
Posted by: RTT
« on: September 06, 2018, 09:30:45 PM »

With the Windows registry editor tool, search for PDFShellTools.PDF.Creator (in the data field only), and delete all the instances of values named FullDetails and PreviewDetails in the key where the the search find that data. Keep searching, and deleting these values, until no more are found.
Now use the manager to define again the properties you what in the details pane.
Posted by: Ed Kopta
« on: September 06, 2018, 08:59:52 PM »

I'm having similar trouble again: custom fields are not appearing in the details pane, though they do show up in the tooltips, infoedit, and everywhere else. I had tried to add a new field, and all of the custom ones vanished. I can't even hide some of the default ones. Checking or unchecking the boxes has no effect on which ones are displayed, and those selections revert to default each time the Manager is opened. Running the command line routine given above as an admin has no effect, even after a reboot. Windows 10.0.17134 Build 17134, 64-bit.
Posted by: ekopta
« on: June 09, 2017, 12:51:17 AM »

Running the command worked fine. Thanks.
Posted by: RTT
« on: June 08, 2017, 03:04:27 PM »

Probably you need to re-register the custom properties in the system. To do this, you may add a dummy custom property, to force the re-registration. Check also if all the the custom properties, you want in the details pane, are set to be visible, i.e. are checked and ordered as you want. To finish, click the manager "apply changes" button and check if now the Shell shows all your properties.

To re-register the custom propertes, instead of the add a dummy custom property trick, you can, from an elevated command prompt, run the command rundll32 "C:\Program Files (x86)\PDF-ShellTools\PDFShellTools.dll",InstallPropertySchema
Posted by: ekopta
« on: June 08, 2017, 05:12:50 AM »

I just updated to the new Windows 10 Home build (version 1703, OS build 15063.332, 64-bit), and my custom fields have gone missing. They still appear in the PDF-ShellTools settings windows, themselves, but they are not displayed in the windows display pane, tooltips, mapping dropdown, or index viewer. I've tried reindexing the pdfs and rebuilding the index (and rebooting, for good measure), but I can't get them to display again. The data is still in the files themselves. How can I get them back?