PDF-ShellTools > General

function is missing in 64bits version


Hi there,

I just discover the PDF-shellTools product and I am testing it to script some treatments on lot of pdf files.
I am on Windows Seven 64bit environment and I want to use SetResetSecurity function but I received an error message from Rundll :

--- Code: ---Error in C:\Program Files (x86)\PDF-ShellTools\PDFShellTools.dll
Entry missing : SetResetSecurity
--- End code ---

the command-line I used is :
Rundll32 "C:\Program Files (x86)\PDF-ShellTools\PDFShellTools.dll",SetResetSecurity PermPass=MonMotDePasse EncLevel=2 -CreateBackup c:\test\a.pdf

I try with PDFShellTools64.dll too, but without success

thank You for the help

Just tried it here (with the trial version too) and, at least the last release (v2.6.3), seems to be working just fine. Tried exactly the command line you posted above. The "entry missing" error will indeed occur if you try to call it from the 64-bit dll, PDFShellTools64.dll, as the functions are only implemented in the 32-bit dll.

By the way, current versions don't need that rundll32 calling schema (I need to update the user's guide). You may just call the more handy command line tool, pdfshelltools.exe, instead, i.e.

"C:\Program Files (x86)\PDF-ShellTools\PDFShellTools.exe" SetResetSecurity PermPass=MonMotDePasse EncLevel=2 -CreateBackup c:\test\a.pdf

Thank You for the reply,

the command-line with the exe file works very fine, but it shows the window " password and security" and requires to click.
What I am looking for is the command-line to put in a loop of a *.bat file to process approximately 400 pdf files.


The .exe version is just a more user friendly calling method. Internally it works as the rundll32 method, calling the function from the .dll too. The behavior will be the same.
If you check the function calling parameters there is a -s used to hide the tool GUI, but this functionality is disabled in the trial versions.

Ok I understand more , I had seen and tested the silent mode but without success  8)
thank You


[0] Message Index


Go to full version