PDF-ShellTools > General

Custom field with multiple text


I would like to add a custom field under property handler with the function like the system.keywords field, where you can add separated text or numbers separated by a semicolon. When I under settings (custom field settings) try to force the multiple text through it will not work the same way. Someone who has tried the same and knows the workaround.

Currently, you can only set that multiple values data type with a manual workaround. I will have it implemented from the manager in the next release.

The workaround consist in manually edit the PDFShellTools.propdesc file, you will find where the program is installed, to add a multipleValues="true" attribute to the typeInfo node of the related property.
After you have your property defined, and registered, open the PDFShellTools.propdesc in a text editor. Locate the propertyDescription node of your property, and add the multipleValues="true" attribute to its typeInfo node (check the attached image for reference). To save the file, and if you haven't executed the text editor with elevated rights, you will have to save it to a work folder and then copy it over the original file.
Now open an elevated command prompt and run the next two commands:
rundll32 "C:\Program Files (x86)\PDF-ShellTools\PDFShellTools.dll",UninstallPropertySchema
rundll32 "C:\Program Files (x86)\PDF-ShellTools\PDFShellTools.dll",InstallPropertySchema
(don't forget to change the path to the PDFShellTools.dll, to reflect your system)

Thanks for reply. I have made the suggested changes but does not seem to have any effect. I have tried with and without selecting "Multi-value text" under edit/Draw pane in custom field settings. I have restarted the machine, but still remains the same. see attachment.

After the attribute multipleValues="true" is added, and file saved back to its original location, you need to execute the command rundll32 "C:\Program Files (x86)\PDF-ShellTools\PDFShellTools.dll",InstallPropertySchema from an elevated command prompt. Have you done this?
Don't forget to change the path "C:\Program Files (x86)\", if you have PDF-ShellTools installed at a different folder.

The UninstallPropertySchema command, I previously stated as needed, is not necessary.

And there is no need to change to "Multi-value text" under the Edit/Draw settings, because if the type is set to "multipleValues", the default draw/editor will assume the Multi-value text anyway.
I've tried it here and this workaround works fine. There is no need to restart windows.

If you use the manager again, to change anything related to the custom fields, you will have to repeat the process, because the manager removes that "multipleValues" attribute from the schema file. Next release have this fixed (check attached screenshot).

The changes you show in your attachment seem to be OK. Even so, you may check the windows event viewer for any error that may be happening in the registration of the property schema.

Perfect!!! The elevated command prompt was the trick. Now it Works perfectly. Thanks


[0] Message Index


Go to full version