PDFrizator > General

No sound

<< < (3/4) > >>

gustavomeeuwes:
Hi! Yessssss!
In notebook presentations with .mp3 and .wma sounds works fine. I set first permissions to open document and now al is OK.
In my PC as you said I have a codec issue. I'm going to reinstall all them.

Thank you very much for your support. I personally hate Powerpoint so PDFrizator is excellent for me.
Thanks again

Gustavo

gustavomeeuwes:
Hi. I'd tried deleting all codecs and nothing.
I'd installed Windows Media Player 11 and I can play presentations with .mp3 sounds. Not with .wma sounds.
The only codecs I have installed in my PC are the WMP defaults (wmpsrcwp.dll and l3codecp.acm (lame mp3).
Maybe for Acrobat is necessary to have installed WMP, although later you don't set as default player.
For .wma sounds maybe an incompatibility between Adobe Reader X and Win XP? I don't know.
.wma files played with WMP are OK.

Regards
Gustavo

RTT:
I don't know much about codecs, and related issues, so I can't help you on this.


--- Quote ---Maybe for Acrobat is necessary to have installed WMP, although later you don't set as default player.
--- End quote ---
My idea is that Acrobat don't respect the selected player option. If I set it to Flash Player, and then in the  Edit - Preferences - Multimedia Trust, disable the Windows Built-In Player, music will not play!

gustavomeeuwes:
Maybe we are expecting too much from Adobe Reader although I think it's the best pdf viewer.
I post issue in Adobe forums, so if I get a solution, I'll send you my comments.
Now I can play presentations with .mp3 sounds and I can start doing them with PDFrizator and enjoy your "the easy to use" soft. I can delete Powerpoint access icon :).
 
Thanks you very much again. It's unusual to receive the support you give me. Your concern, patience and clarity in answers speaks very well about PDFrizator.

Best Regards
Gustavo

gustavomeeuwes:
Hi RTT:
I enclose part of Adobe's answer.

There are two types of rich media in PDF files - "legacy" and "Flash". Legacy media is the type created by Acrobat 8 and earlier, and hands off the playback of the video or audio to an external application such as Windows Media Player, Quicktime, etc. Flash media is the type created in Acrobat 9 and later, and uses the embedded copy of Flash Player in Adobe Reader 9/X and Adobe Acrobat 9/X - it NEVER uses an external application, and NEVER uses the external copy of Flash Player you have installed for running SWF content in your web browser. The embedded version is different, intentionally so that it can block certain types of local and network access which could be used for malicious purposes.

Creation of legacy media was possible in Acrobat 9, but has been removed from Acrobat X. Playback of legacy media in Acrobat/Reader 9 and later is disabled by default, so the user must actively choose to run the content by clicking the document message bar, and/or setting trust options.

The fact you're getting a JavaScript alert indicates the media is being controlled by scripting, and if legacy playback is disabled those functions will not work, hence the errors.

Adobe strongly advises all PDF authors to use Flash media in their PDF files. Legacy media not only suffers from issues with unreliable playback on different computers, but it has a number of known security holes which cannot be entirely closed and have been actively exploited to distribute malware. This is why support for authoring legacy content has been discontinued, and legacy playback should only be allowed in files you completely trust.

So what Adobe is saying is that Adobe Reader uses his built-in player, so if I set Multimedia Trust to allow always only Adobe Flash Player (Three others to never), it should work. But not in my case. An although I set this, each time I open de file the above bar appears asking if I trust.

It's not clear.
Regards
Gustavo

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Reply

Go to full version