Author Topic: No sound  (Read 12324 times)

0 Members and 1 Guest are viewing this topic.

gustavomeeuwes

  • Newbie
  • *
  • Posts: 11
No sound
« on: February 04, 2011, 02:25:35 PM »
Hi:
As Cheyenne's post, I'd made a sample presentacion with sound. Presentation is only 4 pages with photos and automatic transition between pages.
I enclose as music an .mp3 file (a short sample).

Save presentation as .pdf.

In Adobe Reader X - Edit - Preferences - Multimedia Options I set as Preferred Multimedia Player, Adobe Flash Player, since I don't have installed Windows Media Player or Quick Time.
In Adobe Reader X - Edit - Preferences - Multimedia Trust Contents: no changes, Default. I think it's OK.

The first time I open presentation  Adobe Reader ask if I trust the document, Say yes and presentation starts. Presentation is OK, but without sound.
A warning Javascript windows appears saying Acrobat error when playing multimedia clip.

I enclose presentation file.

Your help is welcome.
Best Regards
Gustavo

Note: Sorry for my English but I'm from Argentina and all my softs are in Spanish. Hope you understand it.


RTT

  • Administrator
  • *****
  • Posts: 766
Re: No sound
« Reply #1 on: February 04, 2011, 04:59:48 PM »
I suppose that if you exit from the full screen mode you see a "Some features have been disabled to avoid potential security risks....) message, just above the PDF page? You can use that message Options button to enable the disabled features, telling Acrobat to trust the document.
Or you can edit the Acrobat Multimedia Trust options, menu- Edit - Preferences - Multimedia Trust. There, select the "Other documents" radio button, and set the "Permission for Windows Built-In Player"  and "Permission for Adobe(R) Flash(R) Player" to "Always".

That warning JavaScript window is not appearing here, so maybe Acrobat is failing to start the Flash Player?
I don't have that setup of only Flash player available to play PDF's multimedia content, so I can't test here.

Your PDF sounds are playing OK here.

gustavomeeuwes

  • Newbie
  • *
  • Posts: 11
Re: No sound
« Reply #2 on: February 04, 2011, 06:25:32 PM »
Hi RTT !
Thanks for your reply. I set preferences as you indicate and when starting playback in above window set it to alwalys trust in this doument.
But still javascript windows appears and stop presentation.

Regrads
Gustavo

gustavomeeuwes

  • Newbie
  • *
  • Posts: 11
Re: No sound
« Reply #3 on: February 04, 2011, 06:38:33 PM »
Hi again.
I did another presentation similar to the other but without sound.
Javascript windows doesn't appears but presentation doesn't play auto. I have to change slides with mouse wheel. I tried as default player "windows default player" and "Adobe flash player" boy no one show presentation in auto mode.
I¡m going to try uninstalling Adobre Reader and Adobe Flash Player and install them again. Just in case.
Or may be try Adobe Reader 9 instead of X?

Regards
Gustavo

RTT

  • Administrator
  • *****
  • Posts: 766
Re: No sound
« Reply #4 on: February 04, 2011, 07:17:18 PM »
Quote
But still javascript windows appears and stop presentation.
My best guess is that Acrobat fails to run the Flash player.
But why you don't have the "Windows built-in player" option available?

Quote
Javascript windows doesn't appears but presentation doesn't play auto. I have to change slides with mouse wheel
Probably you forgot to set the "Display duration" for each of the pages? You can select all the pages at once, and set that value to some seconds. If set to -1, the default, pages will not advance automatically.

Quote
Or may be try Adobe Reader 9 instead of X?
Works fine with both here, so the problem is something else.

gustavomeeuwes

  • Newbie
  • *
  • Posts: 11
Re: No sound
« Reply #5 on: February 04, 2011, 07:47:51 PM »
Hi again. Yes, in Multimedia I have four optinos: Windows Built-In Player, Adobe Flash Player, WIndows Media Player and Quick Time. Windows Media Player and Quick I don't have them installed.
I tried with WIndows Built-In Player but the same error. Javascript windows appears.
My PC have Win Xp SP3.
I'd tried also in my notebook Win 7 Ultimate with Adobe Reader set to Windows Built-In Player, and the same. Javascript windows.
I keep trying.
Best regards
Gustavo

RTT

  • Administrator
  • *****
  • Posts: 766
Re: No sound
« Reply #6 on: February 04, 2011, 08:18:25 PM »
While testing for another thing, related to another program, and from a Windows limited account user, I tried your PDF file I got that JavaScript error! I suppose Acrobat needs to access some resources that are protected in user limited accounts. Maybe this is your case?
In this situation, running the Acrobat Reader as Administrator fixes the issue.

gustavomeeuwes

  • Newbie
  • *
  • Posts: 11
Re: No sound
« Reply #7 on: February 04, 2011, 08:26:44 PM »
Hi.
My PC have Win XP SP3. Only one user account created and of course with Administrator privileges.
Notebook, with Win 7, also one account with Administrator privileges.

Regards.
Gustavo


RTT

  • Administrator
  • *****
  • Posts: 766
Re: No sound
« Reply #8 on: February 04, 2011, 08:53:53 PM »
With the limited user account situation, the javascript error window shows only for MP3's. With WMA's plays fine. Maybe you have a codec problem with the player Acrobat tries to use?

gustavomeeuwes

  • Newbie
  • *
  • Posts: 11
Re: No sound
« Reply #9 on: February 04, 2011, 09:24:58 PM »
I'm going to check codecs.
Regards

gustavomeeuwes

  • Newbie
  • *
  • Posts: 11
Re: No sound
« Reply #10 on: February 04, 2011, 09:48:49 PM »
Hi! Yessssss!
In notebook presentations with .mp3 and .wma sounds works fine. I set first permissions to open document and now al is OK.
In my PC as you said I have a codec issue. I'm going to reinstall all them.

Thank you very much for your support. I personally hate Powerpoint so PDFrizator is excellent for me.
Thanks again

Gustavo

gustavomeeuwes

  • Newbie
  • *
  • Posts: 11
Re: No sound
« Reply #11 on: February 04, 2011, 11:28:40 PM »
Hi. I'd tried deleting all codecs and nothing.
I'd installed Windows Media Player 11 and I can play presentations with .mp3 sounds. Not with .wma sounds.
The only codecs I have installed in my PC are the WMP defaults (wmpsrcwp.dll and l3codecp.acm (lame mp3).
Maybe for Acrobat is necessary to have installed WMP, although later you don't set as default player.
For .wma sounds maybe an incompatibility between Adobe Reader X and Win XP? I don't know.
.wma files played with WMP are OK.

Regards
Gustavo

RTT

  • Administrator
  • *****
  • Posts: 766
Re: No sound
« Reply #12 on: February 04, 2011, 11:45:21 PM »
I don't know much about codecs, and related issues, so I can't help you on this.

Quote
Maybe for Acrobat is necessary to have installed WMP, although later you don't set as default player.
My idea is that Acrobat don't respect the selected player option. If I set it to Flash Player, and then in the  Edit - Preferences - Multimedia Trust, disable the Windows Built-In Player, music will not play!

gustavomeeuwes

  • Newbie
  • *
  • Posts: 11
Re: No sound
« Reply #13 on: February 05, 2011, 12:11:52 AM »
Maybe we are expecting too much from Adobe Reader although I think it's the best pdf viewer.
I post issue in Adobe forums, so if I get a solution, I'll send you my comments.
Now I can play presentations with .mp3 sounds and I can start doing them with PDFrizator and enjoy your "the easy to use" soft. I can delete Powerpoint access icon :).
 
Thanks you very much again. It's unusual to receive the support you give me. Your concern, patience and clarity in answers speaks very well about PDFrizator.

Best Regards
Gustavo

gustavomeeuwes

  • Newbie
  • *
  • Posts: 11
Re: No sound
« Reply #14 on: February 05, 2011, 08:14:11 PM »
Hi RTT:
I enclose part of Adobe's answer.

There are two types of rich media in PDF files - "legacy" and "Flash". Legacy media is the type created by Acrobat 8 and earlier, and hands off the playback of the video or audio to an external application such as Windows Media Player, Quicktime, etc. Flash media is the type created in Acrobat 9 and later, and uses the embedded copy of Flash Player in Adobe Reader 9/X and Adobe Acrobat 9/X - it NEVER uses an external application, and NEVER uses the external copy of Flash Player you have installed for running SWF content in your web browser. The embedded version is different, intentionally so that it can block certain types of local and network access which could be used for malicious purposes.

Creation of legacy media was possible in Acrobat 9, but has been removed from Acrobat X. Playback of legacy media in Acrobat/Reader 9 and later is disabled by default, so the user must actively choose to run the content by clicking the document message bar, and/or setting trust options.

The fact you're getting a JavaScript alert indicates the media is being controlled by scripting, and if legacy playback is disabled those functions will not work, hence the errors.

Adobe strongly advises all PDF authors to use Flash media in their PDF files. Legacy media not only suffers from issues with unreliable playback on different computers, but it has a number of known security holes which cannot be entirely closed and have been actively exploited to distribute malware. This is why support for authoring legacy content has been discontinued, and legacy playback should only be allowed in files you completely trust.

So what Adobe is saying is that Adobe Reader uses his built-in player, so if I set Multimedia Trust to allow always only Adobe Flash Player (Three others to never), it should work. But not in my case. An although I set this, each time I open de file the above bar appears asking if I trust.

It's not clear.
Regards
Gustavo