Author Topic: Watermark: Setting Watermark to more that 1 file --> files damaged  (Read 5618 times)

0 Members and 1 Guest are viewing this topic.

paulbittner

  • Newbie
  • *
  • Posts: 3
Hi,

Ich am testing PDF ShellTools with WinXP and Vista. I experienced some strange and very annoying problems.

When I add a watermark (4 lines, text only) to one file it works. BUT if I try to add the same watermark to more that one file usually the first is ok an all the rest of the files is damaged! Using the command-line the result is the same.

A very annoying problem or bug since the possibility to apply functions to many files makes PDF ShellTools powerful. For just one file I could use Adobe Acrobat as well.

Best regards,
Paul

RTT

  • Administrator
  • *****
  • Posts: 768
Re: Watermark: Setting Watermark to more that 1 file --> files damaged
« Reply #1 on: November 22, 2008, 10:39:17 PM »
Hi Paul,
Its an already reported http://www.rttsoftware.com/forum/index.php?topic=262.0 and fixed bug, but I hadn't update the online trial because a new version, v1.0 build 10, with new features and many bug fixes, is going to be released soon. Registered users already have this problem fixed in the build 9 Patch 7.
Probably next week the new version will go online. You can test it yourself then.
Anyway, thanks for reporting, and please if you find something else let me know ;)

paulbittner

  • Newbie
  • *
  • Posts: 3
Re: Watermark: Setting Watermark to more that 1 file --> files damaged
« Reply #2 on: November 23, 2008, 12:46:49 AM »
Hi,

Ok, sounds good. Unfortunately I went to bed at 3 in the morning for two days instead of 10 in the evening testing this bug....  :o/

Well, I noticed a very similar bug with setting the passwords. Is this already reported as well?

Best regards,
Paul

RTT

  • Administrator
  • *****
  • Posts: 768
Re: Watermark: Setting Watermark to more that 1 file --> files damaged
« Reply #3 on: November 23, 2008, 01:22:23 AM »
Quote
Unfortunately I went to bed at 3 in the morning for two days instead of 10 in the evening testing this bug....
Sorry by that ;D but next time ask here in the forum and go to sleep early. I'm sure I will have something to say about posted next morning.

Quote
Well, I noticed a very similar bug with setting the passwords. Is this already reported as well?
No, I'm not aware of that one but I have tested right now, with my current development code, setting the password security to 10 files and the 10 files got security settings set without problem. So, or the bug is already fixed or specific files/parameters are involved. If the problem don't occur every time, try to discover if some parameters, or file(s), are the trigger for it.

paulbittner

  • Newbie
  • *
  • Posts: 3
Re: Watermark: Setting Watermark to more that 1 file --> files damaged
« Reply #4 on: November 23, 2008, 02:01:29 AM »
The error occurs every time to at least half of my tested files. Mayby - and hopefully - that was fixed with your last update regarding the watermarks.

So, I will wait to get your update next week for further testing. When everthing works fine (watermarks, passwords) I will order 2 licenses.

Best regards,
Paul

RTT

  • Administrator
  • *****
  • Posts: 768
Re: Watermark: Setting Watermark to more that 1 file --> files damaged
« Reply #5 on: November 29, 2008, 12:14:27 AM »
PDF-ShellTools version 1.0 build 10 is now oline, so take a look and let me know if some of these problems persist.

paul

  • Guest
Re: Watermark: Setting Watermark to more that 1 file --> files damaged
« Reply #6 on: December 01, 2008, 05:46:06 AM »
Thank you,
I will test it and let you know!
Best regards,
Paul